Preview Window, Info Viewer, may fail to display expected data

English support for the software AllDup
Post Reply
therube
Posts: 322
Joined: 07 Nov 2012, 00:28

Preview Window, Info Viewer, may fail to display expected data

Post by therube »

Preview Window, Info Viewer, may fail to display expected data



There are situations where (at least) Info Viewer / EXIF / Media Info (Plugin)
go to a "busy" state, & where further actions with said plugins, fail.



new instance (so no pre-existing config4.ini)
open AllDup
add a directory of test files

Code: Select all

directory:
	A.exe (alldupportable.exe works, 5 MB)
	M.ocx (mtframe.ocx works, 200 KB)
	a small .wmv (say ~360 KB)
	& 2 small .jpg (say ~90 & 180 KB)
	
select all those files, Copy/Paste, such that they are all dup'd (all within the same directory is fine)

Search Method: Size

Start Search
- Search Results open, & the search result details display in the Preview Window

Expand All
- most likely, A.exe is listed first, followed by the .wmv, then M.ocx, & then the 2 sets of small .jpg
[This, the ordering, at least having the .exe turn up first, looks to be PERTINENT to duplicate the issue.
That said, i have also seen this when only "image" files were used, so no .exe at all, so there are other
"triggers" too.]


Arrow-key down to "A - Copy.exe"
Move mouse cursor over (i.e., hover) the Preview Window
- note that the mouse icon changes to a "busy pointer" & the Preview Window is blank

Arrow-key down to the .wmv
- most likely it will preview (play)

Arrow-key down to the .ocx
- note that again the "busy pointer" returns

Arrow-key down to the .jpg
- note that the "busy pointer" persists & that the actual image is not displayed

(the thumbnails themselves were generated, do exist [in /temp/GUID/],
& the preview of said thumbs do display when you land on the .jpg Group itself)


Quit.
Reopen AllDup
Start Search

- at this point, double-click the Size column, twice (such that it is in ascending size order)

Now follow the steps above, starting with:

Expand All

This time, things work.
The images are displayed, the .ocx displays basic data about it, the .wmv plays,
& the .exe also displays basic data about it.


Similar machinations also exist (at least) with EXIF/Media Info (Plugin).


Messing around futher, may get things back working again, but i'm unsure of set
steps to get it working?
Administrator
Site Admin
Posts: 4046
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: Preview Window, Info Viewer, may fail to display expected data

Post by Administrator »

I did a test with a fresh AllDup Portable v4.5.58.

I arrow down through the search result and every single file was displayed in the file preview pane and the 2 groups with the JPGs are displayed as a group previews.

test file dir:
test files.png
test files.png (9.21 KiB) Viewed 12289 times
therube
Posts: 322
Joined: 07 Nov 2012, 00:28

Re: Preview Window, Info Viewer, may fail to display expected data

Post by therube »

(i can't believe it [again, no less] !!!)

it does happen with "4559-291223".

it looks like it does not happen with 4558.

(but, i could have sworn i did test with 4558?
as it is, i do have both versions .exe in a single directory
all for the purpose of renaming 1 or the other to alldupportable.exe, & testing)

BUT, testing again, i'm not able to duplicate with 4558
(where i'm thinking i must ? have dup'd with 4558, solely by replacing the .exe ?)

anyhow, see if you can dup it with 4559-291223

(doesn't make sense, as i know i purposely must have checked with 4558 knowing
that 4559 is an "a2" ?!)

now maybe it might just be a .dll needs an update or... ?
Administrator
Site Admin
Posts: 4046
Joined: 04 Oct 2004, 18:38
Location: Thailand
Contact:

Re: Preview Window, Info Viewer, may fail to display expected data

Post by Administrator »

I guess you need a newer version because all versions above 4558 are still in develpoment and a lot of changes are done.
therube
Posts: 322
Joined: 07 Nov 2012, 00:28

Re: Preview Window, Info Viewer, may fail to display expected data

Post by therube »

(With a quick looks, looks to be fixed in 4.5.60 :-).)
Post Reply